Back to overview
Degraded

New Backend & Database is down

May 20, 2025 at 05:02pm UTC
Affected services
New Backend & Database

Resolved
May 20, 2025 at 05:03pm UTC

New Backend & Database recovered.

Created
May 20, 2025 at 05:02pm UTC

New Backend & Database is degraded.